VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 Problems and bugs
 Product Features problems
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

dandlyin
VP-ASP New User

USA
73 Posts

Posted - January 23 2006 :  17:05:16  Show Profile  Visit dandlyin's Homepage  Reply with Quote
I'm using the Plus version 6.07. I note that the patch does not contain a corrected shopa_editprodfeatures.asp. A correction to that file was described on 11/26/05 here: http://www.vpasp.com/helpnotes/shopexd.asp?id=717. I believe it should have been a part of this update.

The specific problem I am having is adding an optional feature, which has an extra price. I set it up as a featuretype 'quantity' but it is acting like type 'qtyProduct'. When I set it to a value higher than 1, it adds that number of base products plus this feature. eg base price=$14.99, feature=$3.
If I set both the quantity of the product and the quantity of this feature to 1, the correct value appears- $17.99. If I clear the cart, then add 1 base product and 2 features, it produces a cart with 2 of each and a total price of $35.98.
The product uses a text box to specify the number of products one wants to order, if that makes a difference.
The example may still be here (if I haven't found a fix)
http://www.1stintunes.com/vpasp/default.asp
Under the Services category there is only 1 product and it is the problem.
Help!
Thank you.
Dan Dotson

support
Administrator

4266 Posts

Posted - January 23 2006 :  22:58:39  Show Profile  Visit support's Homepage  Reply with Quote
Dear Dan,

In regard to your first issue, I believe that help note is incomplete.

Before you apply that patch, you should try changing the following:

In shop$db.asp, change:
const xsqloledb="No"

To:
const xsqloledb="Yes"

In regards to your other issue, would it be possible for you to post this question in our helpdesk (http://www.vpasp.com/virtprog/helpdesk) and we will be able to assist you further.

Thank you,

VP-ASP Support
Go to Top of Page

dandlyin
VP-ASP New User

USA
73 Posts

Posted - January 31 2006 :  03:27:56  Show Profile  Visit dandlyin's Homepage  Reply with Quote
The solution to this problem was to use the Feature Type 'Multiplier'. It works fine but it seemed that Quantity should have as well.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000