VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-Cart StoreFront Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 General help me questions
 error ''80040e14'' when attempting to import product
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Starting Member

3 Posts

Posted - August 28 2012 :  11:52:07  Show Profile  Reply with Quote
Hi there,

Currently working on moving our online shop over to VP-ASP (version 7.02.1, yet to add security patches etc. as it's currently off limits to our customers, haven't edited any files save for some css styles). I've been attempting to add a few items at a time via csv files and each time I get the same error message:

Microsoft JET Database Engine error '80040e14'

The SELECT statement includes a reserved word or an argument name that is misspelled or missing, or the punctuation is incorrect.

/{admin area}/shopa_import.asp, line 474

For all of these attempts I've exported via the Products page, and have tried exporting and importing them as both .CSV files and .TXT files. I've tried simply importing the txt file as VP-ASP exported it without changing anything (using semi-colons as delimiters, both including the header row and omitting it) as well as adding just one record, and I've tried a number of programs (Excel, Libre Office, CSV Easy) in order to find one which wouldn't change the formatting of the file.

Nevertheless VP-ASP is spitting out the same error (above) whatever I try. Can anyone tell me if there are any commons tricks to try / mistakes I may be making?

Apologies if I've not explained myself clearly (it's 10 minutes till I get off work, that's my excuse and I'm sticking with it ), I'd be happy to clarify anything.

Thanks for reading!

Starting Member

3 Posts

Posted - August 29 2012 :  10:38:09  Show Profile  Reply with Quote
Decided to use Access to migrate products instead, will delete this if nobody has the same problem.
Go to Top of Page

VP-ASP Expert

758 Posts

Posted - September 12 2012 :  04:19:50  Show Profile  Reply with Quote
i absolutely thinking that there must be problem with your import data. can you try maybe divide the data into several file and you then import the small file one by one. see if all the small files are all failed or just certain files are failed.

Go to Top of Page

Starting Member

3 Posts

Posted - September 12 2012 :  06:27:20  Show Profile  Reply with Quote
Hi Diego,

It's been a while since I worked on the CSV imports, and I've managed to migrate our products with Access instead.

I did try importing a CSV file with just one record, as well as some longer ones, and both were imported in the same format as they were exported, so barring any errors in the software (which seems unlikely as I couldn't find many mentions of this problem) I imagine the problem was with formatting as you mentioned.

I may try this again and have a more thorough read-through of the Developers Manual at a later date. Have you been experiencing similar problems or dealt with this in the past?

Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000