VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 Customization
 Customer registration problem
 New Topic  Reply to Topic
 Printer Friendly
Previous Page
Author Previous Topic Topic Next Topic
Page: of 2

lewisar
Starting Member

United Kingdom
34 Posts

Posted - February 12 2008 :  13:43:16  Show Profile  Reply with Quote
Yes I did originally do that myself, but then I thought, well, that page is only shown after you log in, so you MUST already have registered to get to that page, so it just doesn't need to be there at all does it? Even if your session times out and the first item changes from "Logout" to "Login", I can't see any reason why anyone would want to register again, so I just took it right out.

If I find any circumstances under which it causes problems, I'll let you know!

...and Jorge - it may well be due to me not having set the "no duplicates" flag, but in 6.50 when I first tried it out, if you register and log in, that "Registration" option shows completely blank name and address details - it's only the "Change Address" option which shows the details you originally entered. And I know that my duplicate was caused by me registering twice, because the second time I typed it in I used "Rd" instead of "Road" in my address, so the entries were not quite identical! SO it looks like your problem is not the same as mine after all.

Ade.
Go to Top of Page

webyhost
Starting Member

USA
35 Posts

Posted - February 12 2008 :  19:05:49  Show Profile  Reply with Quote
I am trying something else out and checking to see if that works.
I will post a reply with the results.
If that fix doesn't work I will try the code you posted.

Thanks for the help.
I have to say the vpasp community is excellent!


Go to Top of Page

norik000
Starting Member

USA
43 Posts

Posted - February 13 2008 :  02:48:29  Show Profile  Visit norik000's Homepage  Reply with Quote
- lewisar

If you click on the my account link you will see that non registered users also see that page. And that's why it is a good practice to not remove the link. However, change the behavior of the link to disappear after login.

I guess you missed that out. Anyways I admit, removing the link is better than having a user register again, and again.

-------------------------------
www.Parscat.com
<signature>3D</signature>
Go to Top of Page

lewisar
Starting Member

United Kingdom
34 Posts

Posted - February 13 2008 :  03:14:46  Show Profile  Reply with Quote
Ah! I knew there was bound to be a reason and I'd probably regret it sooner or later! OK, I give in, I'll put it back in the "not logged in" section of code. But as a compromise, I think I may add some text to say something like "please don't do this if you've already registered"!

Thanks

Ade.
Go to Top of Page

smithwahl
Starting Member

2 Posts

Posted - March 21 2008 :  02:13:59  Show Profile  Reply with Quote
Wouldn't you know it. I hav been dealing with duplicate customer records for some time now because I have not had time to deal with it. Come to find out it was the option:

xcheckexistingcustomer

that was set to "No" that was causing the duplicate records.

Thank you for the information. you saved me alot of work.
Go to Top of Page

Lori Titus
VP-ASP New User

126 Posts

Posted - December 03 2008 :  22:46:58  Show Profile  Visit Lori Titus's Homepage  Reply with Quote
I don't know if this is a related problem or not, but:

I have been having an issue where, for unknown reasons, a user is created, but no username or password is saved.

When the person then tries to purchase something, it tells them that the user already exists, please enter username and password, but since nothing exists, they cannot login. I have to go to each one in admin and add a username/password individually, taking up my time and trouble.

Additionally, there are times that the customer gets sent into an endless loop. I think, in these instances, it is a new customer attempting to purchase something without entering a username/password. The system then tells them that they need to enter a username/password, but it does not give them the fields to do so.

I have xcheckexistingcustomer=yes. I'm not certain if there are other fields I should be looking at.

Anyone have any ideas?


The Internet's #1 supplier of honey and beeswax.
Go to Top of Page

SimkaOlssen
Starting Member

4 Posts

Posted - May 22 2009 :  14:09:57  Show Profile  Visit SimkaOlssen's Homepage  Reply with Quote
Самое запретное порно здесь! 50+ категорий.
вокруг клитора порно матуре татарский чат знакомств
[url=http://standsexz.freehostia.com]заварка эротика[/url] [url=http://feeelgooperz.freehostia.com]порно секс мама[/url] [url=http://jaapoolx.twohosting.com]порнуха молодые[/url]
vrotmnenogi
Go to Top of Page
Page: of 2 Previous Topic Topic Next Topic  
Previous Page
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000