VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 General help me questions
 Cannot locate shipping record
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

jackbox
VP-ASP New User

United Kingdom
72 Posts

Posted - January 18 2007 :  13:32:07  Show Profile  Visit jackbox's Homepage  Reply with Quote
Cannot locate shipping record
select * from shipmethods where shipmethod=''

Version 6. Cart is set to read weight field in products (doesn't use shipping table) and set to 'product' under xshippingcalc. It even calculates fine but still throws up that error. I'm no programmer but presume there are two calls going on here.

If theres nothing in xfixedshippingmethod thats the error I get. What SHOULD be in xshippingmethod to correct this or is it a case of rogue code somewhere?

Kidd
VP-ASP Super User

Australia
373 Posts

Posted - January 18 2007 :  22:40:08  Show Profile  Reply with Quote
if you go to shipping->weight

do you have any record there?

you need to add some if you dont
Go to Top of Page

jackbox
VP-ASP New User

United Kingdom
72 Posts

Posted - January 19 2007 :  03:30:45  Show Profile  Visit jackbox's Homepage  Reply with Quote
Well under the VPASP help documents it mentions that if you want shipping calculated per product, you can do so by entering a figure in the 'weight' field in each products details (ie ignore shipping table) and set shippingcalc to 'product'. I must admit I've always used the shipping tables in the past so have no experience of doing it this way but in this instance thats whats required. It should just work but it continues to throw up that error in VPASP 6.

Interestingly I relaced shopshippngcalc.asp with an older version (VPASP 4 or 5) and the error vanished so I can only presume theres a bug somewhere. It appears to be trying to look up a shipping method in the code in shopshippingcalc even though in Admin I've asked it to just read the figure in the weight field for that product instead.

In code terms, I guess shopshippingcalc should be saying "If shippingcalc is set to 'product' - ignore the rest of this code. I'll try comparing the two shopshippingcalc.asp files and see if I can figure out whats going wrong. Given that replacing it with an older file cures the problem, it has to be in there somewhere.
Go to Top of Page

support
Administrator

4266 Posts

Posted - January 21 2007 :  19:44:35  Show Profile  Visit support's Homepage  Reply with Quote
Hi,

If you can log a support ticket via our helpdesk at https://www.vpasp.com/virtprog/helpdesk we will happily take a look at your files to determine if there are any issues.

We have tested this on a default installation of VPASP6.09 and been unable to replicate your issue.

You might want to first make sure you have no shipping methods in your shipmethods table and that xshippingdatabaserecords is set to NO in your configuration settings.

Thank you.

Regards,
Michael
VPASP SUPPORT
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000