VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 General help me questions
 localhost and Firefox
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Starting Member

49 Posts

Posted - January 03 2007 :  14:21:58  Show Profile  Reply with Quote
I'm having an interesting problem that may be a little off topic but I can't seem to figure it out. My localhost version of the site mimics the production/server version until yesterday.

I updated the default.asp with the exact code from shopdisplaycategories.asp (which uses a modified version of tmp_categorytemplate.htm -- so that our homepage would reflect the categories dynamically with descriptions/photos (we only have two categories, no subcats).

Since I did that everytime I launch the site on localhost the page
default.asp and shopdisplaycategories.asp brings up a windows dialog box that says "Prompt" asking me to login with the message:

Enter username and password for "" at http://localhost

It doesn't do this in IE6. Any ideas/direction would be greatly appreciated. Thanks!

VP-ASP New User

110 Posts

Posted - January 03 2007 :  15:48:52  Show Profile  Reply with Quote
You should have placed the vpasp files in a directory in wwwroot (e.g. c:\inetpub\wwwroot\vpasp) and then type in http://localhost/vpasp.

edit: google's your friend (and your worst enemy!): http://blog.satyr.nl/post/89553256 has the fix for it.

Edited by - jubjub on January 03 2007 15:55:37
Go to Top of Page

Starting Member

49 Posts

Posted - January 04 2007 :  08:23:46  Show Profile  Reply with Quote
Thanks jubjub! I have the project setup right (have about 40+ others working fine). I did the Firefox fix in your post and it works fine now. Never knew about the FF about:config command. Handy-dandy!
Go to Top of Page

Starting Member

15 Posts

Posted - April 13 2007 :  07:24:46  Show Profile  Reply with Quote
to all: Was having a similar prob and did a little searching around here's a couple of fixes.
The Login Popup is due to a setting in your Browser settings.
For Firefox:
1. Type "about:config" in the addressbar
2. Scroll down & find the preference named: network.automatic-ntlm-auth.trusted-uris
3. Doubleclick it and type in: localhost
4. Hit "Enter" and you're done.

For Internet Explorer
In your IE Browser:
1. Go to the Top menu "Tools" -> "Internet Options".
2. Then choose the "Advanced" Tab.
3. Then Scroll all the way down and "Uncheck" the Checkbox corresponding to "Enable Integrated Windows Authentication".
4. Then Click the button that says "Apply" and then "OK".
5. Close the browser and in a new browser try http://localhost.
6. You might have to hit Ctrl+F5 and reload the cache.

Still looking for the work-around for Opera...
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000