VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 General help me questions
 All of a sudden Categories don''t show
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Starting Member

4 Posts

Posted - June 02 2002 :  23:40:40  Show Profile  Visit davidff's Homepage  Reply with Quote
Set the system up and have added my categories and subcategories, have started to add product, have been going back and forth between the screens and everything seems to be working fine. Even got to the point that I could set up multiple sizes for an item with price increase no problem. Finished adding a product and saved, and then went to eat dinner, came back about two hours later to contiune to add product. Added two more product items, had to login as it had timed out. Wanted to check something, so hit the shop button and it brought up the categories, no problem, but when I selected the categoriy I was working on it came back with an can't find the page. tried a couple more times, same thing. Since I had been gone for a while, decided to close everything and shut down the system. brought everything back up, reloaded the system with the command and it loaded the main screen and hit shop, this time no categories were loaded. I checked to see if they were still there and everything is still there all my categories and subcategories are still there along with all the products that I had added. over 130 at this point.

What am I doing wrong that I've lost my categories and before that I couldn't get my product page to display. I checked I didn't change any column display numbers or anything like that, all I did was walk away from adding product and came back to add more.

Help. I have another 400 product to add by Tuesday evening, I can't afford to start over at this point.

Thanks much

David Hasiba

David W. Hasiba

Starting Member

19 Posts

Posted - July 14 2004 :  12:12:31  Show Profile  Visit imulus's Homepage  Reply with Quote
We are having the EXACT same problem, we have over 140 categories and an select group of these categories is not showing up at all.

Any ideas?

Go to Top of Page


4262 Posts

Posted - July 14 2004 :  14:07:37  Show Profile  Visit support's Homepage  Reply with Quote
VP-ASP generates very plain HTML.

Categories will not show if they are hidden or your are selecting them by language or by customer. If you know ASP I suggest you put a trace into shopdisplaycategories.asp to see the exact SQL being generated. Locate this line in shopdisplaycvategores.asp

OpenRecordSet dbc, rs, sql

add a debug line before it so it look like

debugwrite sql
OpenRecordSet dbc, rs, sql

VP-ASP Support

Go to Top of Page

Senior Member

United Kingdom
1898 Posts

Posted - July 14 2004 :  16:27:32  Show Profile  Visit devshb's Homepage  Reply with Quote
there's a generic problem when you get over around 100 categories:

we've added a topic on our forum which explains how you can fix this with a single line change:


Simon Barnaby
[email protected]
Web Design, Online Marketing and VPASP addons
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000