VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 Electronic Gateways
 SSL URL different to standard site URL
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

bjdani
Starting Member

4 Posts

Posted - June 04 2007 :  06:46:27  Show Profile  Reply with Quote
Hi all,

We've gone ahead and got dedicated SSL set up but the URL is different (eg http://www.<sitename>.com.au and https://secure.<sitename>.com.au)

I seem to be encountering problems when switching to SSL on the payments page. It loses the plot and the cart has nothing in it.

Is this because of the URL being different? Would I need to have the SSL set up so the URL is https://www.<sitename>.com.au instead?

Any help anyone can provide me with would be greatly appreciated...

Thanks in advance,
Bruce

devshb
Senior Member

United Kingdom
1898 Posts

Posted - June 04 2007 :  07:09:24  Show Profile  Visit devshb's Homepage  Reply with Quote
yes; it's because the url is different (the "http" or "https" doesn't mater, but the subdomain does)

you'd need to point your ssl certificate to the same domain as your non-ssl area for it to work properly, otherwise the sessions won't be available when the customers move onto ssl.

see also the blurb here which explains the kind of problems/solutions that you can get:
http://www.bigyellowzone.com/shopexd.asp?id=64

Simon Barnaby
Developer
[email protected]
www.BigYellowZone.com
Web Design, Online Marketing and VPASP addons
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000