VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 Problems and bugs
 Fatal Communication Error
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

masha
Starting Member

USA
8 Posts

Posted - March 21 2007 :  13:18:31  Show Profile  Reply with Quote
Howdy,

I'm running two VP-ASP based carts on my virtual server. One of them runs just fine (5.00), the other doesn't (5.50).

Intermittenly, the users notice their shopping carts emptying out, which wouldn't be such a bad thing if it weren't for the fact that this website is the majority of our business.

It's a Win2K3 Enterprise server running IIS 6.0, I don't control the updates for it, but I assume it's reasonably current. We're using Access databases (although porting to mySQL in the next few weeks).

Every time the cart empties out (session resets), I get this error in the System log:

"A process serving application pool 'First Books' suffered a fatal communication error with the World Wide Web Publishing Service. The process id was '26816'. The data field contains the error number."

The process ID varies every time, as I have IIS running as separate processes for each site, so each reset causes the W3WP process to recycle. I disabled recycling on the application pool to see if that would have any effect, but I didn't.

Logic would dictate that if it was a server problem, my other site would be affected, but it doesn't seem to care.

Any ideas?

support
Administrator

4266 Posts

Posted - March 21 2007 :  21:30:25  Show Profile  Visit support's Homepage  Reply with Quote
Hi there,

You may have an open connection somewhere in the code possibly that is causing the pressure to build until the server cracks.

Other than that it would be hard top second guess what the issue is without actually been able to look at the site itself unfortunately.

You may need to post this one in our online help desk so our support team can have a look for you.

https://www.vpasp.com/virtprog/helpdesk/

Thanks
Cam

VP-ASP Support
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000