VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 General help me questions
 HTTP SSL strange error.
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Adam_Hawkins
VP-ASP New User

United Kingdom
56 Posts

Posted - March 12 2007 :  04:26:30  Show Profile  Reply with Quote
When clicking the order now button after entering address details etc you get an internet connection error:

To attempt fixing network connectivity problems, click Tools, and then click "Diagnose Connection Problems..." along with the usual cant display page error.

the protocol changes from HTTP to HTTPS which causes the error. when I force it back to HTTP I can access the next page and complete the transaction.

I think its something to do with the SSLs in IIS which I believe are turned on. I have used the existing certificate from our old website which runs on vpasp5.

Does anyone have any idea how I can get this to work? I can't really use the site without encryption.



Adam_Hawkins
VP-ASP New User

United Kingdom
56 Posts

Posted - March 13 2007 :  07:13:31  Show Profile  Reply with Quote
I've been looking into it and I have SSL setup on the correct port number, my browser settings are correct too and the firewall allows it.

The issue may come down to the fact that the server is running 2 websites.

The standard old website which has been running happily for over a year, this of course runs on port 80.

The new site which is giving problems is running on a different port just so it is not conflicting with the current site and is not available for the public to see unless they know the port number. I have also used the same certificate for the old site and the new site.

Could any of these factors cause this issue that I am having?

Go to Top of Page

Adam_Hawkins
VP-ASP New User

United Kingdom
56 Posts

Posted - March 14 2007 :  05:41:17  Show Profile  Reply with Quote
We also use secpay and as such have to go through secpayshopcheckout.asp if that is any help
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000