VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 Problems and bugs
 _ad. being a reserved word
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

devshb
Senior Member

United Kingdom
1898 Posts

Posted - February 17 2007 :  07:18:45  Show Profile  Visit devshb's Homepage  Reply with Quote
Don't use "_ad." as part of your form/file names -

I've just spent about 2 hours trying to debug a problem we had with something we were working on, and thought I'd mention it here in case anyone else has/had the same problem. It's not a vpasp bug, and won't effect any standard vpasp pages, but is relevant for things like renaming the admin login page or creating custom-built content pages etc.

A very strange thing, when the name of the asp ends with "_ad.asp" (eg "myscreen_ad.asp"), something (not sure whether it's norton, or anti-spyware/anti-adware software or something else) stops everything from the form tag up to the </form> bit from being output'd/processed/loaded in the html. It doesn't have to be an asp either; anything with "_ad." seems to cause problems.

So, make sure your admin login page doesn't get renamed to anything_ad.asp etc, otherwise you might not get the login form displayed and you'll be beating your head in frustration for hours like I did. It's also very important for content pages, eg don't create a page called "linktous_ad.asp".

Simon Barnaby
Developer
[email protected]
www.BigYellowZone.com
Web Design, Online Marketing and VPASP addons

Edited by - devshb on February 17 2007 07:56:08

Kidd
VP-ASP Super User

Australia
373 Posts

Posted - February 18 2007 :  22:06:28  Show Profile  Reply with Quote
i think its not the _ad, i tried to renamed my admin to shopadmin_ad.asp and didnt not encounter any problem. i know some anti virus causes asp pages to hang. this is from technet

http://support.microsoft.com/kb/q295375/
Go to Top of Page

devshb
Senior Member

United Kingdom
1898 Posts

Posted - February 19 2007 :  01:39:20  Show Profile  Visit devshb's Homepage  Reply with Quote
I think it was my anti-adware software which I downloaded free as part of the google taskbar stuff for internet explorer. The annoying thing was that the problem did indeed not seem to happen for anyone else (I assume because they haven't installed that software), but happened to me for any forms that posted to *_ad.asp files.

Simon Barnaby
Developer
[email protected]
www.BigYellowZone.com
Web Design, Online Marketing and VPASP addons
Go to Top of Page

Kidd
VP-ASP Super User

Australia
373 Posts

Posted - February 19 2007 :  06:07:56  Show Profile  Reply with Quote
hmm something must have triggers the anti virus to not load the form or something like that then :)
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000