VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 Problems and bugs
 v6.09 Content Header displays twice
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

dandlyin
VP-ASP New User

USA
73 Posts

Posted - August 26 2006 :  18:29:02  Show Profile  Visit dandlyin's Homepage  Reply with Quote
shopcontent.asp at line 88

Response.write "<div align='left'><a href='" & getconfig("xhome") & "'>Home</a> " & SubCatSeparator & " " & message & "</div>"

then at line 100

response.write message & "<BR><BR>"

Remove 'message' from the string in either line 88 or line 100

The template tmp_content.htm contains the variable 'message' as well so solution 1 is recommended- and do not use a template.
BTW, the template as supplied fails with message 'field number not in database'. This does not happen with the 'About' content. What's that about?
The help section on content needs help- many places where 'category' should be 'content', template is described twice- and other fields aren't described at all.

Thanks,
Dan Dotson

support
Administrator

4266 Posts

Posted - August 28 2006 :  20:11:27  Show Profile  Visit support's Homepage  Reply with Quote
Dear Dan,

The header does now display twice - once as part of the new Breadcrumb feature and again as the actual header.

I am unsure of the cause of the error you have described - "Field Number Not In Database". If you would like us to look into this, please submit a ticket in our helpdesk at http://www.vpasp.com/virtprog/helpdesk

Thank you for pointing out the mistake in the content help, this will be updated shortly.

Kind regards,
Claire
VP-ASP Support
Go to Top of Page

devshb
Senior Member

United Kingdom
1898 Posts

Posted - August 28 2006 :  20:44:19  Show Profile  Visit devshb's Homepage  Reply with Quote
I'd guess that the number not in database error might be due to a string of [number] in the content record's text somewhere, but that's just a guess.

we've run into problems when we have things with square brackets in our actual data, as the template-processing then treats it like a template field.

Simon Barnaby
Developer
[email protected]
www.BigYellowZone.com
Web Design, Online Marketing and VPASP addons

Edited by - devshb on August 28 2006 20:44:44
Go to Top of Page

dandlyin
VP-ASP New User

USA
73 Posts

Posted - August 29 2006 :  08:17:35  Show Profile  Visit dandlyin's Homepage  Reply with Quote
Thank you Simon, square brackets were in fact the source of the error.
I can now use a template to make my content pages simpler.
Regards,
Dan Dotson
Go to Top of Page

devshb
Senior Member

United Kingdom
1898 Posts

Posted - September 10 2006 :  06:38:04  Show Profile  Visit devshb's Homepage  Reply with Quote
In case anyone's reading this for the "header shows twice" issue, we also noticed that when we coded-up our "content-management enhancement" addon, so for our addon we tweaked it so that you can use any content column for your breadcrumb source (defaulting to use the messagetype so that you don't get duplicate header text) -

CMS Enhancement addon:
http://www.bigyellowzone.com/shopexd.asp?id=125

Simon Barnaby
Developer
[email protected]
www.BigYellowZone.com
Web Design, Online Marketing and VPASP addons

Edited by - devshb on September 10 2006 06:38:48
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000