VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 database location in shop$config.asp
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Starting Member

11 Posts

Posted - March 31 2006 :  05:08:20  Show Profile  Reply with Quote
Hi, pls help me out, I just can't figure this one out. I've copied the database to locate at : host\database\xyz.mdb and the vpasp is located in "host\wwwroot\shop\". I gathered the database location variable to change in shop$config.asp must be "..\..\database" but it just won't work. When I connect to the default.asp, it forever complain with this error message:

Server.MapPath() error 'ASP 0175 : 80004005'

Disallowed Path Characters

/shop/shop$db.asp, line 289

The '..' characters are not allowed in the Path parameter for the MapPath method.

And yet, I have the same set up in a VM image and it works fine. Pls let me know what I've done wrong or anything I could diagnose the problem with.

Cheers, Jeffrey

VP-ASP New User

89 Posts

Posted - March 31 2006 :  07:38:49  Show Profile  Reply with Quote
hi there,
you need to get the exact location of this file. look at you diag_dbtest.asp file online and test your file write.

it will give you the location of your licence file:

directoryname:\websites\website_address\folder\ etc.

you need to place this in then follow the location to your database

hope this helps

Edited by - nwright77 on March 31 2006 07:39:15
Go to Top of Page

Senior Member

United Kingdom
1898 Posts

Posted - March 31 2006 :  13:47:39  Show Profile  Visit devshb's Homepage  Reply with Quote
another possibility is to contact your host and get them to turn on the relative pathnames allowed option on the site/server; usually it'd be allowed, but some hosts default it to off by default.
you should be able to ask your host to switch it on to allow relative pathnames; just give them the error message and ask them to allow it if you want to.

Simon Barnaby
[email protected]
Web Design, Online Marketing and VPASP addons
Go to Top of Page

Starting Member

11 Posts

Posted - April 01 2006 :  20:02:31  Show Profile  Reply with Quote
Thanks for all those who responded!! You guys are great!
The support folks at vpasp has given me the answer I'm looking for and it works! Here's their reply and it might help others down the track:

Try changing your shop$config.asp to have these settings:

xdatabasetype = "Drive"

xdblocation="C:/intepub/database" (this should be the path to the database folder on your server - C:/... is just an example)

Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000