VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 Add-ons for VP-ASP
 Getting uspsrealtime to work
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

dcwebman
VP-ASP New User

USA
127 Posts

Posted - January 22 2006 :  12:51:35  Show Profile  Reply with Quote
I have downloaded the uspsrealtime add-on and just can't get it to work. First, it's obviously downlevel because the USPS doesn't require password anymore and it's still discussed in the uspsrealtime code. I entered my userid that was issued by the USPS and think I have everything else set correctly for testing. The error I keep getting is:

An unexpected system error has occurred. Please try again later or contact the System Administrator.
listed twice.

I have tried tracing through the code and this error is returned from the SendXML function. The xmlresult is:
xmlresult=<Error> <Number>80040320</Number> <Description>An unexpected system error has occurred. Please try again later or contact the System Administrator. </Description> <Source></Source> </Error>

I have tried various things like not sending the password. When I signed up on USPS for the web tools I gave it the website I am planning on using the finished code on. I am developing it not on the production site so just in case I registered again using the development site. Still no luck.

Any ideas what's going wrong? Is there a newer version of the uspsrealtime code that works?
Thanks,
Jeff

support
Administrator

4266 Posts

Posted - January 23 2006 :  00:21:05  Show Profile  Visit support's Homepage  Reply with Quote
With issues like this it is best to send directly to our help desk as we do not monitor this forum.


To get started see if your version has the following lines of code in shpo$db.asp around line 2234:

dim tmprc
cleansemessage msg,tmprc
if tmprc=4 then msg=""

Replace with:

'dim tmprc
'cleansemessage msg,tmprc
'if tmprc=4 then msg=""

Some releases will not have these present.

If you do not have these please submit a ticket to the online help desk at:

http://www.vpasp.com/virtprog/helpdesk

Thank you
VP-ASP Support
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000