VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 Add-ons for VP-ASP
 How to use fedex.mdb in MySQL based VPASP600 store
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

james2005
Starting Member

10 Posts

Posted - December 23 2005 :  15:10:46  Show Profile  Reply with Quote
I wish to use the fedex.mdb database as it is the only fedex database available from the AddON, my problem is my store(VPASP606) is running on MySQL, and evrytime it excute the fedex.asp, it was trying to find "countries" table from the MySQL database instead from the fedex.mdb.

I did change the setting in fedexconfig.asp as below
const xfedexdb="fedex.mdb"
const fedexdblocation="D:/inetpub/httpdocs/database/"
const xfedexdatabasetype="MSAccess"

The MSAccess is the DSN i configure at ODBC setting for MS Access Driver, and the connection to the fedex.mdb was tested successful for this DSN.

I also found that in Amin Menu, under Advanced, there is a field xotherdatabases, (as explained,it is used with xothertables. It lists the database names in which those tables can be found. If left empty, then the other tables are assumed to be in the same database as the products. ) So, i set xotherdatabases=fedex.mdb and xothertables=countries....But it still look for "countries" table in MySQL database which is of nor existance .....
very much grateful if someone can help or give some hint where to troubleshoot it further..

support
Administrator

4266 Posts

Posted - December 23 2005 :  16:08:35  Show Profile  Visit support's Homepage  Reply with Quote
Please try setting

const xfedexdb="fedex"
const fedexdblocation="D:\inetpub\httpdocs\database"
const xfedexdatabasetype="drive"

Radek Rekas
VP-ASP Support
Go to Top of Page

james2005
Starting Member

10 Posts

Posted - December 23 2005 :  16:45:24  Show Profile  Reply with Quote
quote:
Originally posted by support

Please try setting

const xfedexdb="fedex"
const fedexdblocation="D:\inetpub\httpdocs\database"
const xfedexdatabasetype="drive"

Radek Rekas
VP-ASP Support


Thank you for so fast repond, i had tried, but still same, i also change the xotherdatabase to fedex instead of fedex.mdb, but also same... The error is "Microsoft OLE DB Provider for ODBC Drivers error '80004005'

Table 'MySQL_Database.countries' doesn't exist

/fedex.asp, line 512

Note : I use a DSN to point my MySQL databse to a remote server rather than the localhost, as i set up the MySQL database in remote host. But the access database is in localhost, i did also set up a separate DSN for it, and tested connection OK.
Go to Top of Page

support
Administrator

4266 Posts

Posted - December 24 2005 :  01:10:11  Show Profile  Visit support's Homepage  Reply with Quote
Hi,

The below modification only applies for customers running on a windows based server:

Please change line 152 of fedexinterface.asp from:
shopopendatabase connection

to:
OpenOtherDatabase connection,xfedexdb,xfedexdblocation,xfedexdatabasetype

CheckDatabaseOpen connection

Radek Rekas
VP-ASP Support
Go to Top of Page

Sergei_Sh
Starting Member

Australia
7 Posts

Posted - March 14 2006 :  03:33:41  Show Profile  Reply with Quote
Hi!

I'm currently testing VP-ASP Deluxe on my local machine.
I have made the changes recommended by Radek in this topic:

const xfedexdb="fedex"
const xfedexdblocation="C:\Inetpub\wwwroot\vpasp\database"
const xfedexdatabasetype="drive"

and

change line 152 of fedexinterface.asp from:
shopopendatabase connection
to:
OpenOtherDatabase connection,xfedexdb,xfedexdblocation,xfedexdatabasetype
CheckDatabaseOpen connection


And now I'm getting the following error on the fedex.asp page:

Error Type:
Server.MapPath(), ASP 0172 (0x80004005)
The Path parameter for the MapPath method must be a virtual path. A physical path was used.
/vpasp/shop$db.asp, line 276

What should I do?
Thanks.

Go to Top of Page

support
Administrator

4266 Posts

Posted - March 15 2006 :  00:50:32  Show Profile  Visit support's Homepage  Reply with Quote
In IIS you need to set Parent Paths to not be disabled.

At the top level Default Web Site folder select properties by right clicking on the folder.

In the Home Directory tab click on Configuration.

In Options ensure Enable parent paths is ticked.

If this does not work you will need to post a ticket in the help desk so we can look into this further.

Thanks,
Cam

VP-ASP Support
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000