VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 General help me questions
 shopping car is empty?
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

cho7536
Starting Member

36 Posts

Posted - May 17 2005 :  14:29:53  Show Profile  Reply with Quote
Hi,

I have customer who trying to shop online. lot of them say that their shopping cart was empty while they shop thru web. Anybody have an idea? is this caused by session?
Thank you.

June

cho7536
Starting Member

36 Posts

Posted - May 19 2005 :  17:12:33  Show Profile  Reply with Quote
Thank you very much for fast reply.

I emailed hosting company(crystaltech.com) and they ask me what programming language I use and what is the code I am using to assign a value to the session? I know I am using asp for programming language. but what is my answer for the other question?
Please let me know.
Thank you in advance.

June


Go to Top of Page

cho7536
Starting Member

36 Posts

Posted - May 19 2005 :  17:22:26  Show Profile  Reply with Quote
My prior question to web hosting was if there is option I can enable session longer enough.

Go to Top of Page

greatphoto
VP-ASP Super User

USA
304 Posts

Posted - May 21 2005 :  21:58:45  Show Profile  Reply with Quote
quote:

My prior question to web hosting was if there is option I can enable session longer enough.



I doubt this question is related to your "cart was empty" problem. However, the answer to it is this: You can adjust the session timeout using the cart administration. Change xsessiontimeout to some new value. The default value is 20 minutes. The developer's manual warns not to set this too high because of the strain it can add to the server, but gives no specific details on the consequences or dependencies in choosing a time.



Go to Top of Page

greatphoto
VP-ASP Super User

USA
304 Posts

Posted - May 21 2005 :  22:04:23  Show Profile  Reply with Quote
quote:

I have customer who trying to shop online. lot of them say that their shopping cart was empty while they shop thru web. Anybody have an idea? is this caused by session?



If this problem is recurring for you with multiple customers, then start trying to add things to the cart yourself. If it works, then try back in 1 hour to see if you can add new items, then another hour later, and another. You may find that it occasionally fails for you even though you already have cookies enabled. If so, you may have the same problem that I experienced.

See: http://www.vpasp.com/virtprog/vpaspforum/topic.asp?TOPIC_ID=3424

The solution to this was a small mod in one of the VPASP files.

If you are able to reproduce the problem yourself, be sure to tell us.

Go to Top of Page

rvaga
VP-ASP Super User

USA
254 Posts

Posted - May 21 2005 :  22:33:42  Show Profile  Reply with Quote
This happens on occasion on my site as well. Greatphoto, if the code change is fairly simple, could you post it here? Hey, maybe this would even keep my every couple of day "unknownlanguage" boogey-man from showing up!

Go to Top of Page

greatphoto
VP-ASP Super User

USA
304 Posts

Posted - May 22 2005 :  01:01:59  Show Profile  Reply with Quote
Hi rvaga-

Yes, I think this very well could be related to your "unknownlanguage" error.

I posted the solution here just now:
http://www.vpasp.com/virtprog/vpaspforum/topic.asp?TOPIC_ID=3424

Go to Top of Page

cho7536
Starting Member

36 Posts

Posted - May 22 2005 :  12:47:03  Show Profile  Reply with Quote
Great Thanks to Nathan

I just added

dim rc' end mod'*****************************************************' open database and see if we are doing with html or not' See if this is a next page request or first time'******************************************************ShopInitinitializesystem

to displayproducts.asp, and It seems solved problems. I am going to wait couple more days and still hear complains from customers.
Thanks again.

Go to Top of Page

greatphoto
VP-ASP Super User

USA
304 Posts

Posted - May 22 2005 :  15:37:35  Show Profile  Reply with Quote
I hope you added just the "ShopInit" and not the other stuff. The other stuff was already there in version 5.50. (Is that the version you are using?)

Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000