VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 General help me questions
 site setup
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

jeberlan
Starting Member

13 Posts

Posted - February 24 2004 :  06:20:33  Show Profile  Reply with Quote
I'm developing one site and I'm using two boxes. One on an XP Pro box at home and (shhhh) a 2000 box at work. The 2000 box is setup just fine but the XP box is giving me problems. It seems like everytime I make the database folder as a web-sharable folder it marks the whole folder as read-only. How do I place the database into a virtual folder without making it read-only? I've read the setup FAQ's for XP and have followed exactly. The database is in a folder by itself and that folder is a virtual folder and I cannot remove the read-only flag from the folder properties. I'm assuming the host will be able to fix this but I can't do my developement until I do.

jonmadrid
VP-ASP New User

USA
192 Posts

Posted - February 24 2004 :  07:44:41  Show Profile  Visit jonmadrid's Homepage  Reply with Quote
Are you using IIS on the XP machine? Thats probably the easiest method but it didn't really sound like thats what you were doing. Just create your virtual directory (site) in IIS for your shopping cart site, then give the database folder write permissions (right click the folder >> Properties >> check the 'write' checkbox). I just tried it on an XP machine and it worked perfectly.

If thats what you've done and its still not working, it's beyond me. Maybe someone else here will know.

All the best,

Jon Madrid
--------------------
Madrid Communications
Web Design, Development, and Hosting
www.madridcom.com
Go to Top of Page

jeberlan
Starting Member

13 Posts

Posted - February 24 2004 :  09:15:32  Show Profile  Reply with Quote
I have IIS running on the XP box. I have the read and the write privileges unchecked on the DB folder.
Go to Top of Page

jonmadrid
VP-ASP New User

USA
192 Posts

Posted - February 24 2004 :  10:23:24  Show Profile  Visit jonmadrid's Homepage  Reply with Quote
You need those checkboxes 'checked'... indicating that Read and Write permissions are allowed. Unchecked will disallow those options. If you cant read and you can't write, you can do virtually nothing with that directory from a web perspective.

You want 'Read' checked on all folders in the site (so you can access them via browser, a.k.a. Read them) and 'Write' checked on only the database folder (so the contents of that folder can be edited). Try that and see if it solves your problems.

All the best,

Jon Madrid
--------------------
Madrid Communications
Web Design, Development, and Hosting
www.madridcom.com
Go to Top of Page

Cam
VP-ASP Super User

Australia
361 Posts

Posted - February 24 2004 :  19:11:16  Show Profile  Visit Cam's Homepage  Reply with Quote
Hi there,

Have a look at the following faq on our site:

http://www.yourvirtualstore.net/rocksalt_v.5/faqs.asp?id=75

This may help with setting permissions on your machines. You can change the checks on each folder to suit your requirements.

Cheers,
Cam

*************************************
Cam Flanigan
YourVirtualStore Sales
e-mail:
http://www.vpasp.com/sales/shopcustcontact.asp
web: http://www.yourvirtualstore.net

Build you own YourVirtualStore!!!
www.yourvirtualstore.net
*************************************
Go to Top of Page

siraj
VP-ASP New User

USA
194 Posts

Posted - February 24 2004 :  21:26:50  Show Profile  Visit siraj's Homepage  Reply with Quote
Yup,
Cam got that right... and very help for the people who just setting up the directory permsions.
GOOD LUCK.
SJ.

[email protected]
Go to Top of Page

jeberlan
Starting Member

13 Posts

Posted - February 25 2004 :  18:16:01  Show Profile  Reply with Quote
Nope. Still not there. The instruction you pointed to are for 2000. XP has no Security tab.
I even tried moving the database to the root of C: and changing to a "Drive" type in the Shop$config file. Still no dice. I can read all day, but can't write.

Go to Top of Page

siraj
VP-ASP New User

USA
194 Posts

Posted - February 25 2004 :  23:53:33  Show Profile  Visit siraj's Homepage  Reply with Quote
Hi..The problem is with your OS folder option. They be needed to be changed to "use simple file sharing"
Please refer the post
http://vpasp.com/virtprog/vpaspforum/topic.asp?TOPIC_ID=2166
GOOD LUCK.
SJ.

[email protected]
Go to Top of Page

jeberlan
Starting Member

13 Posts

Posted - February 26 2004 :  19:45:10  Show Profile  Reply with Quote
Sirag,
Not quite right, but it got me onto the right path.
First disable Simple File Sharing. This will present the Security tab on the Folder options. Then enable Write permissions for Everyone.
That did it. I'm up and running. Thanks for the help.
Is this be something that VPASP should add to the install instructions for XP Pro? I found nothing about Simple File Sharing in the install docs.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000