VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 Problems and bugs
 Encryption errors
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Starting Member

United Kingdom
3 Posts

Posted - December 19 2003 :  03:02:28  Show Profile  Visit tonyhrx's Homepage  Reply with Quote
When I put encryption on, the 'decryption' seems to fail when processing the order - ie credit card information is still encrypted. Is this a problem other users have found or am I doing something really stupid?

Tony Horrocks

VP-ASP New User

61 Posts

Posted - December 18 2004 :  16:30:54  Show Profile  Reply with Quote
I am having the same problem. For instance, one order that came in had the credit card field populated with a string of untelligible numbers. The person placing the order also called up to say that the error occurred. VPASP support: what's the problem?


Edited by - EPseja on December 18 2004 16:33:37
Go to Top of Page

VP-ASP New User

72 Posts

Posted - December 18 2004 :  22:22:54  Show Profile  Visit eabrams's Homepage  Reply with Quote
Are you using a payment gateway? If so you need to add the code to decode the number before you send it to you processor.

<!-- #include file="shophash.asp" -->


'Added code to decrypt credit card before submit to processoron
cardNumber = EnDeCrypt(rsorder("ocardno"), EncryptKey)


Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000