VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 General help me questions
 Can''t write to Database
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Carl15220
Starting Member

4 Posts

Posted - November 26 2003 :  22:52:07  Show Profile  Reply with Quote

Hi, I'm very new to this, and trying out the demo of vpasp.
After many tries I finally got it to read but I can't get it to write. This is what I get:
Database Read: Database can be read
Database Write: Database cannot be written
Verify that the database is in a folder that has both read and write access
Microsoft Message
Open Messages


Error count=1
Error #-2147217911
Error desc. -> Cannot update. Database or object is read-only.
Database Permissions: Database permissions tested OK

I've gone through each folder countless time to make sure their right, and always get the same message.
I have each folder on my hard drive listed as database and vpasp.
The Database folder under web sharing has no ticks in Read or Write.
The Vpasp folder under web sharing has the tick in Read.
Under IIS the Vpasp folder in properties Virtual Directory Read is ticked.
Tab Directory Security Anonymous access is ticked.
Again under IIS Database properties Virtual Directory A directory located on this computer is ticked, and no tick next to Read, Write or Directory Browsing.
Under Directory Security there's no tick for Anonymous Access.

Anyone who can offer some help would be greatly appreciated.

Thanks




arte
Starting Member

30 Posts

Posted - November 27 2003 :  21:02:21  Show Profile  Reply with Quote
Read you post again, it says in the error message that the directory or d/base is "read only". That's the reason for the "write" error.

Put a tick in the "write" selection in the directory permissions and/or the database.

That should get you going.



Go to Top of Page

Carl15220
Starting Member

4 Posts

Posted - November 27 2003 :  22:03:22  Show Profile  Reply with Quote
Thanks for the reply arte,
I've even put a tick in every Read & Write box in both the database and my vpasp folder and still get the same error message. I've closed the window and started a new window and I get the same message.

Thanks

Go to Top of Page

siraj
VP-ASP New User

USA
194 Posts

Posted - November 29 2003 :  02:28:52  Show Profile  Visit siraj's Homepage  Reply with Quote
Hi there,
I assume that you are using Access.
The following steps may solve your problem.
1. Right click on the folder where your Access db.
2. Properties -->Security
3. Click on Add tab.
4. Select Everyone and then Add
5. Then select the everyone and mark Full control & Apply
Thats it... You are done.

If you are still having trouble, mail me at
[email protected]
GOOD LUCK.
SIRAJ.


Edited by - siraj on November 29 2003 02:29:22
Go to Top of Page

Carl15220
Starting Member

4 Posts

Posted - November 30 2003 :  22:11:02  Show Profile  Reply with Quote
Hi Siraj,
I'm using the can version of vpasp with no modifications, on XP Pro.
I created a directory on my hard drive called database and moved the shopping500.mdb into it. I also created a folder called vpasp that holds all the files.

I right clicked on my database folder, Properties, and there's no Security tab or any add a tab button.
The Sharing tab tells me to move this folder to the Shared Documents folder to make it available to others, but when I moved it, it's asks for a new file name because the file name "database" is already in use.

Go to Top of Page

siraj
VP-ASP New User

USA
194 Posts

Posted - December 01 2003 :  11:54:00  Show Profile  Visit siraj's Homepage  Reply with Quote
Carl,
When you right click on the folder ->Properties Then, you will seethe followings in XP Pro.
General...Sharing...Security...
I was talking about the 3rd "Security" tab. If you dont see that then you need to do some setting at OS . I really
dont know where it is.
I hope you can do by sharing but I never test it.
Follow this as you dont see the Security Tab. By going to sharing.
1. Check on Share this folder
2. Give a name
3. Then Click on Permisions
5. Click on Add tab.
6. Select Everyone and then Add
7. Then select the everyone and mark Full control & Apply.
I did not test this. Once ou made this, you might need to change shop$config.asp file for Xdblocation.

As you are testing and just using in your local machine, I would just keep the db with rest of the VP-ASP files and paly around.
Make sure that you have made the changes in shop$config.asp file.


Edited by - siraj on December 01 2003 11:55:28
Go to Top of Page

Carl15220
Starting Member

4 Posts

Posted - December 01 2003 :  23:15:21  Show Profile  Reply with Quote
siraj,
Thanks for the help with that, it was my OS with the folder options, they be needed to be changed to "use simple file sharing". Once I changed that the security tab showed up and I added "everyone" to my list and it worked.

Thanks again,
Carl



Edited by - Carl15220 on December 02 2003 07:19:51
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000