VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 VP-ASP 7.0 Questions
 return from Worldpay APPEARS to fail
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

jru
Starting Member

United Kingdom
11 Posts

Posted - February 04 2012 :  07:29:46  Show Profile  Reply with Quote
Hi,

I am confused and pulling my hair out!

I am trying to implement V7 and the gateway is Worlpay (we're moving over to VPASP from another purpose built solution) and everything thing works fine going to WP, within WP and the payment is authorised and then returns to our site and puts out the following (incorrect!) message;

Your credit card transaction failed
Please select another payment method

I've logged into our Worldpay account and checked the payment has been authorised and credited - it has
The order is added to the orders table with WorldPay as the Payment Type and Authorization Transid=2234428787 AVS=2222 Rawauthcode=A
is returned but yet the transaction notifies the customer that it has failed - as I said it is driving me crazy!!!

Any help or advice or pointers would be greatly appreciated as this is obviously stopping us going live :-(

g3nnin
VP-ASP Super User

209 Posts

Posted - February 22 2012 :  18:33:16  Show Profile  Reply with Quote
Hi,

Have you tried contacting support through their helpdesk? Seems there is an incorrect configuration in your Worldpay gateway.

However, I think this happens when the domain name is different when you return back to your site. For example, before going to Worldpay gateway, your domain use HTTPS and when returns the domain use HTTP.


Hope this helps!
Go to Top of Page

jru
Starting Member

United Kingdom
11 Posts

Posted - February 23 2012 :  05:36:07  Show Profile  Reply with Quote
Hi,

Yes was all sorted - discussed with VPASP support and WorldPay support and I'd made a mistake (changed a file locally and not uploaded it!) :-)

Martin
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000