VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 General help me questions
 Paypal with multiple currencies
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Starting Member

34 Posts

Posted - October 23 2011 :  01:21:49  Show Profile  Reply with Quote
I have VPASP 6.5 and currently use PayPal website payments pro for checkout using GBP. I'm adding additional currencies and having an issue. I've adjusted the paypalprodconfig.asp file to set the x_currencycode to either GBP or EUR depending on the current session(cid) of VPASP. So if the user is in GBP it will set to GBP and if in EUR it sets it to EUR. Now the problem is when the user processes the payment, it goes through as the correct currency, however it sends the total amount to paypal as if it were in GBP. VPASP displays everything correctly even through the emailed receipt. Everything in Euros shows correctly. It seems that just the value being sent to paypal doesn't adjust. I do have the currency setup with a standard 1.5 conversion rate from GBP.

Any ideas? I think I must be missing something in one of the paypal files to convert the value before sending.

VP-ASP Expert

723 Posts

Posted - October 28 2011 :  04:40:35  Show Profile  Reply with Quote
i thought that you can only set x_currencycode to the currency code that is your default currency in your vpasp website.

say that your vpasp website have EUR as default, Currencyvalues table would have conversionvalue set to 1 for the EUR.
and your paypal file x_currencycode = "EUR". i don't think there is a method you can have multi currency set in Paypal file, while your default vpasp site only using 1 single default EUR currency.

this is what i thought.

Go to Top of Page

VP-ASP Super User

209 Posts

Posted - October 28 2011 :  13:12:22  Show Profile  Reply with Quote

I noticed that there is a help-note that might the solution for your problem. You could check it in this page:


However, you might need to change the code a little bit, as I noticed that it's for v7.0.

Hope this helps!
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000