VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 Problems and bugs
 Ampersand in the catdescription
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

rce7144
Starting Member

18 Posts

Posted - January 27 2011 :  12:35:32  Show Profile  Reply with Quote
Is there any way to use an ampersand character or a quote character in the catdescription? Example: Parts & Supplies or 4"x3"

If I use the ampersand, I get an error when the catagory is click on the store front.

Is there a way to not have the url include the catdescription in the link and just have the url reference the categoryid only?

diegomilito
VP-ASP Expert

Argentina
723 Posts

Posted - January 27 2011 :  21:04:54  Show Profile  Reply with Quote
use & for ampersand and " for double quote,

complete is at :
http://rabbit.eng.miami.edu/info/htmlchars.html

Diego m.
Go to Top of Page

rce7144
Starting Member

18 Posts

Posted - January 27 2011 :  21:27:19  Show Profile  Reply with Quote
I tried that and it does not work. When the category link is clicked in the store front, the catdescription is passed through the url in the address bar of your browser. The code to generate the url link retains the special characters and makes them part of the url which gives and incorrect address. Try a test with a category called A&B, then try to go into the category from the store front and notice what happens.
Go to Top of Page

carfin
VP-ASP Expert

United Kingdom
948 Posts

Posted - January 28 2011 :  03:51:50  Show Profile  Reply with Quote
I have loads of category descriptions that include the & symbol and it has never caused a problem.
This is how our first category url shows in the address bar
shopdisplaycategories.asp?id=1&cat=Lamps+%26+Lighting
How are you adding the category descriptions to your category table? Is it through the admin panel, or straight into the table or via an upload? And which version of VP-ASP are you using?

Regards,

Carrol
www.deanston-electrical.co.uk
Go to Top of Page

rce7144
Starting Member

18 Posts

Posted - January 28 2011 :  08:18:47  Show Profile  Reply with Quote
I am adding the categories in the admin panel ... I have also tried it by adding the category in the table and importing it. I am using Version 7. Here is the url from the address bar: http://vpasp7.roederindustries.com/shopdisplayproducts.asp?id=2384&cat=M%26amp%3BR+TriLoc+Carrier+Sheets
What version are you using?
Go to Top of Page

carfin
VP-ASP Expert

United Kingdom
948 Posts

Posted - January 29 2011 :  04:23:21  Show Profile  Reply with Quote
I am still using v6.5 and I have the character setting iso-8859-1. To check your character settings go to Advanced Settings > International > Language > Edit Language and find "langcharset" If the setting is iso-8859-1 then try changing it to UTF-8 or vice versa, save the changes, reset your language and see if it helps. Not sure what else could be causing the url to include the html code for the &s in your links. Perhaps a word with support might be the best option.

Regards,

Carrol
www.deanston-electrical.co.uk
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000