VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 VP-ASP 7.0 Questions
 Payment Gateway not working after upgrade
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Starting Member

6 Posts

Posted - November 22 2010 :  15:24:03  Show Profile  Reply with Quote
I was able to install the upgrade in a new directory. However what I did was copy the entire website to the new directory and created an identical copy of the mssql database with a different name. Then updated the config file to make sure it points to the new mssql database. I tested the shop and everything worked just the same. Then I performed the upgrade. I did this so that nothing would affect the existing shop. I couldn't take a chance of anything going wrong and we will use the new directory as the main website.

But now after spending days getting the shop all configured and setup, everything looks and works great, except the payment gateway isn't working. It appears that the order gets submitted successfully yet the payment processing does nothing. We are using Sage (formerly EFT). I followed their upgrade instructions exactly. When an order is placed and a credit card is entered, a message comes up with the order number and it looks like a successful order. Yet the payment processor did not get the order.
I called the pmt processor (Sage) and they said the problem isn't on their end as they did not receive anything, no order. I've done this numerous times, still no order goes through to the payment processor. When I go back to the old site, orders do go through.
Please help, I don't know where else to check.

Oh also, it is running version 7.01.

Starting Member

6 Posts

Posted - November 23 2010 :  21:29:45  Show Profile  Reply with Quote
turns out there are 2 files that need to be modified. The instructions state to modify config/shop$config.asp but you also need to modify admin/config/shop$config.asp.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000