VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 VP-ASP 7.0 Questions
 Having Trouble Logging Into admin
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

FCS-Webmaster
VP-ASP New User

Canada
90 Posts

Posted - March 17 2010 :  17:54:07  Show Profile  Visit FCS-Webmaster's Homepage  Reply with Quote
I'm upgrading from version 5.5 to version 7.0 and I am trying to setup VPASP locally. I went through all the basic upgrade steps then tried to login. I get a message "Your userid/password cannot be located." I try the forgot password and when I enter my user name I get a message "Your username cannot be located." I then opened up the database and looked at the users table. To my surprise the user names and passwords are all stored as binary numbers for example "116.105.52.198.213" is one of the user names.

I tried changing the user name and password for one of the user names and then tried logging in and I still can't login

Any idea what I did wrong?

creativechaos
VP-ASP New User

Australia
64 Posts

Posted - March 18 2010 :  08:21:54  Show Profile  Visit creativechaos's Homepage  Reply with Quote
Hi,

I recently had a similar issue.

With VPASP 7.0 the admin user details are encrypted as a requirement for PCI compliance.

Something appears to have gone a little awry in the upgrade process for you but you should be able to do the following to resolve the issue.

1. You will need to directly modify the username and password in the tblusers table of the website's database. Change these two values to plain text rather than the encrypted versions you are currently seeing. Save your database table changes if necessary.

2. Open up the file admin/convertadminpassword.asp in a text editor and change the lines:

ShopCheckAdmin ""
if session("admintype") <> "SUPER" then response.end

To:

'ShopCheckAdmin ""
'if session("admintype") <> "SUPER" then response.end

Save this file and upload to your server.

3. In the web browser point to http:// yoursite . com /admin/convertadminpassword.asp

4. Click the button "Encrypt Admin Password"

5. Reverse the changes you made in step 2 (ie remove the two single quote characters) and re-upload the convertadminpassword.asp file to your server.

6. Clear all session variables from your browser and try logging in again.


If you take another look in the database, you should see that the username and password will be encrypted again but this time they should be encrypted correctly.

Hope this helps.

Cheers,

Michael Dunkley
Creative Chaos
http://www.creativechaos.com.au
Go to Top of Page

FCS-Webmaster
VP-ASP New User

Canada
90 Posts

Posted - March 22 2010 :  13:56:15  Show Profile  Visit FCS-Webmaster's Homepage  Reply with Quote
I get a "Unauthorized administrator" error when I try to load that file (/admin/convertadminpassword.asp) and get transferred to shoperror.asp
Go to Top of Page

creativechaos
VP-ASP New User

Australia
64 Posts

Posted - March 22 2010 :  18:03:54  Show Profile  Visit creativechaos's Homepage  Reply with Quote
Hi there,

Have you ensured that you commented out the lines indicated in my previous post? The alterations noted in step 2 in the instructions above to the convertadminpassword.asp should ensure you don't get that error message about an unauthorized administrator.

Hope this helps.

Cheers,

Michael Dunkley
Creative Chaos
http://www.creativechaos.com.au
Go to Top of Page

FCS-Webmaster
VP-ASP New User

Canada
90 Posts

Posted - March 23 2010 :  10:46:35  Show Profile  Visit FCS-Webmaster's Homepage  Reply with Quote
Hi Michael

I don't know what I was thinking yesterday, but I some how got the steps mixed up. I did step 2 and it's now working properly.

Thanks for your help.
Go to Top of Page

savvymedias
VP-ASP New User

191 Posts

Posted - April 12 2010 :  01:39:28  Show Profile  Visit savvymedias's Homepage  Reply with Quote
Just for others, I had this issue and was getting error messages, and it was the site caching from the old site. I had to delete all cookies, etc. and open an incognito browser (Chrome) in order to get in AND in order to see all of the menu items for the new version.
Go to Top of Page

FCS-Webmaster
VP-ASP New User

Canada
90 Posts

Posted - September 23 2010 :  17:37:33  Show Profile  Visit FCS-Webmaster's Homepage  Reply with Quote
I just got into the VPASP 7 SP1 beta program. I can do the steps above and I can then login to the admin. The catch is if I download the access database and try and login on my local VPASP installation it won't work. If I upload a copy of the Access database with user information encrypted locally it won't work.
Go to Top of Page

faolie
VP-ASP New User

89 Posts

Posted - February 20 2011 :  13:04:27  Show Profile  Visit faolie's Homepage  Reply with Quote
Worked for me. Brilliant! Thanks Michael.
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000