VP-ASP :: Shopping Cart Software

Shopping Cart Software Solutions for anywhere in the World

US/Canada(Toll Free): +1 888 587 2278
Europe/UK: +44 (020) 7193 9408
Australia/New Zealand: +61 3 9016 4497

VP-ASP Shopping Cart Customer Forum

Home | Profile | Register | Active Topics | Members | Search | FAQ
Username:
Password:
Save Password
Forgot your Password?

 All Forums
 VPCart Forum
 Problems and bugs
 Adding Products Manually
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

jsenick
Starting Member

USA
4 Posts

Posted - January 26 2009 :  16:55:21  Show Profile  Visit jsenick's Homepage  Reply with Quote
I am trying to add a product. The Category "Select" drop down is not populated - but Category is required.

cayars
Starting Member

USA
49 Posts

Posted - January 26 2009 :  21:39:46  Show Profile  Visit cayars's Homepage  Reply with Quote
Make sure you've added your categories to the system before adding products. Also make sure the category IS NOT hidden.
Go to Top of Page

jsenick
Starting Member

USA
4 Posts

Posted - January 27 2009 :  09:22:13  Show Profile  Visit jsenick's Homepage  Reply with Quote
I have about 40 Categories so far with 7 of them being top level and the rest subs. None of these are hidden. When I try to add a product, the category list is not populated. If I add a product via the database, it does not show up on the site either. At this point I have only Categories visable.
Go to Top of Page

carfin
VP-ASP Expert

United Kingdom
948 Posts

Posted - January 28 2009 :  04:42:54  Show Profile  Reply with Quote
Hi,

try checking in the Categories set up in Admin that all the Higher Categories (the ones with sub categories) should have Subcategories field dropdown set to Yes. For all sub categories (the ones you want to add products to) the Subcategories field dropdown should be set to No.

Regards,

Carrol
www.deanston-electrical.co.uk
Go to Top of Page

devshb
Senior Member

United Kingdom
1898 Posts

Posted - January 28 2009 :  05:34:05  Show Profile  Visit devshb's Homepage  Reply with Quote
When it comes to setting up categories/prodcategories, you'd probably find both modules in our category-bundle addon very useful:

BYZ055 - Product/Category Fixing/Reporting Utils for VP-ASP:
http://www.bigyellowkey.com/mysoftware_product_details.asp?prdid=263&opu=n

BYZ014 - Admin Category Tree for VP-ASP:
http://www.bigyellowkey.com/mysoftware_product_details.asp?prdid=202&opu=n

You can get those separately, or in a single bundle:
BYZ109 - Category Bundle for VPASP:
http://www.bigyellowkey.com/mysoftware_product_details.asp?prdid=311&opu=n

Something I've noticed a few times is that on some instances of mysql, some of the columns which should be null actually have an empty ascii character in them (ie they're not truly null, they've got an empty string in them), and that causes problems, but that only seems to happen in some rare instances on initial setups of demo data rather than going forwards when you create new ones. (either way that'd be picked up by the by055 tool)

Simon Barnaby
Developer
[email protected]
www.BigYellowZone.com
Web Design, Online Marketing and VPASP addons
Go to Top of Page

jsenick
Starting Member

USA
4 Posts

Posted - January 28 2009 :  19:20:35  Show Profile  Visit jsenick's Homepage  Reply with Quote
I want to thank everyone for their help. It turns out that I did have the Subcategories set to Yes as Carrol suggested. I can now associate the products to categories while adding products but there still are no products visible. I am using the registered VP6.5 Plus with a SQL2005 DB.

I do appreciate all your help!
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
Snitz Forums 2000